Projekt

Allgemein

Profil

Support #2780

Person Person

WFS-Test 2.0 läuft nicht an

Von Ticketmelder GDI-DE vor 8 Monaten hinzugefügt. Vor 7 Monaten aktualisiert.

Status:
Rückfrage
Priorität:
Hoch
Zugewiesen an:
Peter Kochmann
Kategorie:
INSPIRE Download Service (DA)
Zielversion:
-


Zugehörige Tickets

Beziehung mit GDI-DE Testsuite - Support #1068: Einzeltests WFS werden nicht ausgeführtErledigt

Historie

#1 Person Von Gerd Weber vor 8 Monaten aktualisiert

  • Zugewiesen an wurde von Gerd Weber zu Gregor Scharf geändert
  • Kategorie wurde auf INSPIRE Download Service (DA) gesetzt

Kannst Du bitte prüfen ob das dieselbe Ursache wie bei Ticket #1068 sein könnte?

#2 Person Von Gerd Weber vor 8 Monaten aktualisiert

  • Privat wurde von Ja zu Nein geändert

#3 Person Von Peter Kochmann vor 8 Monaten aktualisiert

Vielleicht ähnlich.
Aber im aktuellen Fall (weitere URL mit gleichen Symptomen folgen) ist es egal, ob dem GetCapabilities-Request der Parameter namespaces mitgegeben wird oder nicht.

#5 Person Von Anja Litka vor 8 Monaten aktualisiert

Ergebnis im INSPIRE Validator:

GetFeature Request = https://www.wfs.nrw.de/geobasis/wfs_nw_inspire-geografische-bezeichnungen_dtk25texte?NAMESPACES=xmlns%28gn%2Chttp%3A%2F%2Finspire.ec.europa.eu%2Fschemas%2Fgn%2F4.0%29&OUTPUTFORMAT=text%2Fxml%3B+subtype%3Dgml%2F3.1.1&REQUEST=GetFeature&RESULTTYPE=hits&SERVICE=WFS&TYPENAMES=gn%3ANamedPlace&VERSION=2.0.0

Response:

Expect no exception: Service returned an exception: Internal Server Error

HTTP status code is 200: Response status code:400 is not in acceptable list of status codes

Root element is FeatureCollection:
The service returned an unexpected exception: 'Internal Server Error; Internal Server Error Abort: error executing a SQL query: Unknown error 0x80050199'. Check the request parameters, which are partially determined from the Capabilities, previous requests or other metadata. Ensure that the service supports the data and functionalities published in the Capabilties and ensure that referenced data exist.

folgenden [CITE-Forum]-Thread zu WFS 2.0 no data available gefunden: http://lists.opengeospatial.org/pipermail/cite-forum/2015-December/001564.html

#6 Person Von Anja Litka vor 8 Monaten aktualisiert

Versuch, den Dienst in QGIs zu laden - Fehlermeldung:

2019-07-19T15:15:15 1 Herunterladen von Objekt schlug fehl: Error downloading http://www.wfs.nrw.de/geobasis/wfs_nw_inspire-geografische-bezeichnungen_dtk25texte?SERVICE=WFS&REQUEST=GetFeature&VERSION=2.0.0&TYPENAMES=gn:NamedPlace&COUNT=1 - server replied: Bad Request
2019-07-19T15:15:15 1 Wiederhole Anfrage http://www.wfs.nrw.de/geobasis/wfs_nw_inspire-geografische-bezeichnungen_dtk25texte?SERVICE=WFS&REQUEST=GetFeature&VERSION=2.0.0&TYPENAMES=gn:NamedPlace&COUNT=1: 1/3
2019-07-19T15:15:15 1 Herunterladen von Objekt schlug fehl: Error downloading http://www.wfs.nrw.de/geobasis/wfs_nw_inspire-geografische-bezeichnungen_dtk25texte?SERVICE=WFS&REQUEST=GetFeature&VERSION=2.0.0&TYPENAMES=gn:NamedPlace&COUNT=1 - server replied: Bad Request
2019-07-19T15:15:15 1 Wiederhole Anfrage http://www.wfs.nrw.de/geobasis/wfs_nw_inspire-geografische-bezeichnungen_dtk25texte?SERVICE=WFS&REQUEST=GetFeature&VERSION=2.0.0&TYPENAMES=gn:NamedPlace&COUNT=1: 2/3
2019-07-19T15:15:15 1 Herunterladen von Objekt schlug fehl: Error downloading http://www.wfs.nrw.de/geobasis/wfs_nw_inspire-geografische-bezeichnungen_dtk25texte?SERVICE=WFS&REQUEST=GetFeature&VERSION=2.0.0&TYPENAMES=gn:NamedPlace&COUNT=1 - server replied: Bad Request
2019-07-19T15:15:15 1 Wiederhole Anfrage http://www.wfs.nrw.de/geobasis/wfs_nw_inspire-geografische-bezeichnungen_dtk25texte?SERVICE=WFS&REQUEST=GetFeature&VERSION=2.0.0&TYPENAMES=gn:NamedPlace&COUNT=1: 3/3
2019-07-19T15:15:15 1 Herunterladen von Objekt schlug fehl: Error downloading http://www.wfs.nrw.de/geobasis/wfs_nw_inspire-geografische-bezeichnungen_dtk25texte?SERVICE=WFS&REQUEST=GetFeature&VERSION=2.0.0&TYPENAMES=gn:NamedPlace&COUNT=1 - server replied: Bad Request

#7 Avatar?id=734&size=24x24 Von Gregor Scharf vor 7 Monaten aktualisiert

  • Status wurde von Neu zu In Bearbeitung geändert

Ich bin mir nicht sicher, aber kann es sein, dass nur Java 8 geht und Java 7 den HTTPS/TLS-Handshake nicht durchführen kann? Wir verwenden Java 7.

https://www.ssllabs.com/ssltest/analyze.html?d=www.wfs.nrw.de&s=93.184.132.181&hideResults=on --- siehe "Not simulated clients (Protocol mismatch)" (evlt. muss man was aufklappen)


Log-Auszug Testsuite-2:

INFO: 2 * Client out-bound request
2 > POST https://www.wfs.nrw.de/geobasis/wfs_nw_inspire-geografische-bezeichnungen_dtk25texte
2 > Accept: application/xml,application/soap+xml
2 > Content-Type: application/xml
2 > User-Agent: GDI-Testsuite
<?xml version="1.0" encoding="UTF-8"?><wfs:GetFeature xmlns:wfs="http://www.opengis.net/wfs/2.0" count="25" service="WFS" startIndex="0" version="2.0.0">
<wfs:Query xmlns:ns53="http://inspire.ec.europa.eu/schemas/gn/4.0" typeNames="ns53:NamedPlace"/></wfs:GetFeature>

Jul 19, 2019 2:46:55 PM org.opengis.cite.iso19142.util.DataSampler acquireFeatureData
WARNING: Failed to parse response entity using POST binding for feature type {http://inspire.ec.europa.eu/schemas/gn/4.0}NamedPlace
com.sun.jersey.api.client.ClientHandlerException: javax.ws.rs.WebApplicationException: net.sf.saxon.trans.XPathException: javax.net.ssl.SSLHandshakeException: Received fatal alert: handshake_failure
        at com.sun.jersey.client.urlconnection.URLConnectionClientHandler.handle(URLConnectionClientHandler.java:155)

Das entscheidene Wort hier ist wohl handshake_failure. Das findet man auch in dem Link mit dem SSL-Test.

#8 Person Von Anja Litka vor 7 Monaten aktualisiert

  • Zugewiesen an wurde von Gregor Scharf zu Peter Kochmann geändert

Zuweisung geändert, mit Bitte um Prüfung und ggf. Konfiguration von HTTPS

#9 Person Von Anja Litka vor 7 Monaten aktualisiert

  • Status wurde von In Bearbeitung zu Rückfrage geändert

#10 Person Von Peter Kochmann vor 7 Monaten aktualisiert

  • Priorität wurde von Mittel zu Hoch geändert
  • Zugewiesen an wurde von Peter Kochmann zu Gregor Scharf geändert

Die oben unter #5 und #6 aufgeführten Requests funktionieren doch alle! Was soll ich hierbei jetzt tun?

#11 Person Von Anja Litka vor 7 Monaten aktualisiert

  • Zugewiesen an wurde von Gregor Scharf zu Peter Kochmann geändert

Es ging nicht um die Abfragen, sondern um die Überprüfung bzgl. SSL:
https://www.ssllabs.com/ssltest/analyze.html?d=www.wfs.nrw.de&s=93.184.140.89&hideResults=on
https://www.ssllabs.com/ssltest/analyze.html?d=www.wfs.nrw.de&s=93.184.132.181&hideResults=on

Die Abfragen im QGIS funktionieren, da war ein Fehler meinerseits das Problem.

Beim INSPIRE Validator läuft der Test gegenüber

#12 Person Von Anja Litka vor 7 Monaten aktualisiert

möglichen 1. Fehler gefunden

#13 Person Von Peter Kochmann vor 7 Monaten aktualisiert

  • Zugewiesen an wurde von Peter Kochmann zu Anja Litka geändert

Tut mir leid - ich kann nicht ganz folgen.
Wo wird das denn angegeben? Im Test-Szenario wird doch nur der URL zum Aufruf des Dienstes benannt.

#14 Person Von Anja Litka vor 7 Monaten aktualisiert

Korrekt. Ich habe das Capabilities-Dokument heruntergeladen, bearbeitet und wieder hochgeladen.

#15 Person Von Gerd Weber vor 4 Monaten aktualisiert

  • Beziehung mit Support #1068: Einzeltests WFS werden nicht ausgeführt wurde hinzugefügt

Auch abrufbar als: Atom PDF