Projekt

Allgemein

Profil

Support #784

Person Person

Validierungs-Fehler CSW

Von Ticketmelder GDI-DE vor etwa 3 Jahren hinzugefügt. Vor 7 Monaten aktualisiert.

Status:
Abnahmephase
Priorität:
Niedrig
Zugewiesen an:
Janis Blank
Kategorie:
OGC CSW 2.0.2 AP ISO 1.0

Beschreibung

Sehr geehrte Damen und Herren,

ich versuche derzeit mit der GDI-Testsuite die CSW-Schnittstellen-Validierung durchzuführen. Am Beispiel pycsw habe ich versucht zunächst die CSW-Level-1.1-Prüdung durchzuführen. Leider scheitert die Prüfung obwohl nach manueller Sichtung des CSW-Server-Responses alles in Ordnung erscheint. Als URL habe "http://demo.pycsw.org/cite/csw?service=CSW&version=2.0.2&request=GetCapabilities" verwendet.

Ich bin mir nicht sicher ob ein Bedienfehler meinerseits oder ein anderes Problem vorliegt.

level1.1.zip (5,16 KB) level1.1.zip Janis Blank, 24.10.2018 10:54
level1.2.zip (6,46 KB) level1.2.zip Janis Blank, 24.10.2018 10:54
level1.3.zip (7,19 KB) level1.3.zip Janis Blank, 24.10.2018 10:54
level1.4.zip (6,94 KB) level1.4.zip Janis Blank, 24.10.2018 10:54
level1.5.zip (4,26 KB) level1.5.zip Janis Blank, 24.10.2018 10:54

DMS

2019-05-02 182918 pycsw Anzeigen (116 KB) Gregor Scharf, 02.05.2019 16:33

Historie

#1 Von Anonym vor etwa 3 Jahren aktualisiert

  • Kategorie wurde auf OGC CSW 2.0.2 AP ISO 1.0 gesetzt
  • Zugewiesen an wurde auf Janis Blank gesetzt
  • Zielversion wurde auf GDI-DE Testsuite Release 2.1.29 gesetzt
  • Privat wurde von Ja zu Nein geändert

Fehlermeldung:

FAILURE: A URL for the GetCapabilities operation must be provided at "ows:OperationsMetadata/ows:Operation[@name=''GetCapabilities'']/ows:DCP/ows:HTTP/ows:Get/@xlink:href". The element was found but the contained text "" does not seem to be a valid URL. The test cannot continue.

Im Capabilities-Dokument findet sich jedoch der Bereich:

<ows:OperationsMetadata>
<ows:Operation name="GetCapabilities">
<ows:DCP>
<ows:HTTP>
<ows:Get xlink:type="simple" xlink:href="http://demo.pycsw.org/cite/csw"/>
<ows:Post xlink:type="simple" xlink:href="http://demo.pycsw.org/cite/csw"/>

#2 Person Von Janis Blank vor fast 3 Jahren aktualisiert

  • Status wurde von Neu zu Rückfrage geändert
  • Zugewiesen an wurde von Janis Blank zu Anonym geändert

#4 Von Anonym vor fast 3 Jahren aktualisiert

  • Zugewiesen an wurde von Anonym zu Janis Blank geändert

#5 Von Anonym vor fast 3 Jahren aktualisiert Privat

Ja, ich würde so verfahren! Ich schreibe nach Aktualisierung dazu dann eine Nachricht ans Ticket

#6 Von Anonym vor fast 3 Jahren aktualisiert

  • Zielversion wurde von GDI-DE Testsuite Release 2.1.29 zu GDI-DE Testsuite Release 2.1.30 geändert

#7 Von Anonym vor mehr als 2 Jahren aktualisiert

  • Zielversion wurde von GDI-DE Testsuite Release 2.1.30 zu GDI-DE Testsuite Release 2.1.31 geändert

#10 Avatar?id=734&size=24x24 Von Gregor Scharf vor etwa 1 Jahr aktualisiert

  • Priorität wurde von Mittel zu Niedrig geändert
  • Status wurde von Rückfrage zu Neu geändert

#12 Avatar?id=734&size=24x24 Von Gregor Scharf vor etwa 1 Jahr aktualisiert

  • Dokument pycsw wurde hinzugefügt

#13 Person Von Janis Blank vor etwa 1 Jahr aktualisiert

Die Tests generieren ihre eigenen Capabilities-Abfragen, welche keinen Versionsparameter hatten. Der Server muss dann die höchstmögliche Version liefern. Als das noch 2.0.2 war, gab es keine Probleme, aber pycsw liefert jetzt 3.0, was die Namespaces verändert und dazu führt, dass sich der Test im Dokument nicht mehr zurechtfindet.

Eine neue Version der CSW-Tests, die auf 2.0.2 bestehen, findet sich im Repository und im Anhang.

#14 Avatar?id=734&size=24x24 Von Gregor Scharf vor 7 Monaten aktualisiert

  • Status wurde von Abnahmebereit zu Abnahmephase geändert

Woran sehe ich denn, dass dieses Ticket erfolgreich bearbeitet wurde? ;)

Hier ist noch (oder zeitlich schon wieder) relativ viel rot oder? ;)

2019-05-02 182918 pycsw

#15 Avatar?id=734&size=24x24 Von Gregor Scharf vor 7 Monaten aktualisiert

  • Dokument 2019-05-02 182918 pycsw wurde hinzugefügt

Auch abrufbar als: Atom PDF