Projekt

Allgemein

Profil

Fehler #792

Person

Metadaten-Testklasse, test: gdide_3.2_2_bedingungen, falsche Fehlermeldung

Von Ticketmelder GDI-DE vor mehr als 3 Jahren hinzugefügt. Vor 4 Tagen aktualisiert.

Status:
Erledigt
Priorität:
Mittel
Zugewiesen an:
-
Beginn:
Abgabedatum:
% erledigt:

0%

Geschätzter Aufwand:

Beschreibung

Tatsache: useConstraints-Element fehlt im Metadatensatz
erwartete Fehlermeldung laut ATS: "Fehler: Es muss ein MD_LegalConstraints-Element vorhanden sein".
tatsächliche Fehlerausgabe: FEHLER: Es muss einer der Begriffe "copyright", "patent", "patentPendig", "trademark", "license", "intellectualPropertyRights", "restricted", "otherRestrictions" in einem der MD_LegalConstraints/useConstraints/MD_RestrictionCode-Einträge vorhanden sein.

Test-MD_useConstraints-fehlt.xml (61,1 KB) Test-MD_useConstraints-fehlt.xml Sabine Schütze, 16.11.2016 11:27

Historie

#1 Von Anonym vor mehr als 3 Jahren aktualisiert

  • Kategorie wurde auf GDI-DE Metadaten v1.1 gesetzt
  • Zielversion wurde auf GDI-DE Testsuite Release 2.1.29 gesetzt
  • Privat wurde von Ja zu Nein geändert
  • Zugewiesen an wurde auf Anonym gesetzt

#2 Von Anonym vor mehr als 3 Jahren aktualisiert

Hallo Sabine,

kannst du einen Metadatensatz anfügen.

Danke und Gruß
Sven

#3 Person Von Sabine Schütze vor mehr als 3 Jahren aktualisiert

siehe Datei Test-MD_useConstraints-fehlt.xml

#4 Von Anonym vor mehr als 3 Jahren aktualisiert

  • Zielversion wurde von GDI-DE Testsuite Release 2.1.29 zu GDI-DE Testsuite Release 2.1.30 geändert

#5 Von Anonym vor etwa 3 Jahren aktualisiert

  • Zielversion wurde von GDI-DE Testsuite Release 2.1.30 zu GDI-DE Testsuite Release 2.1.31 geändert

#6 Von Anonym vor etwa 3 Jahren aktualisiert

  • Status wurde von Neu zu Rückfrage geändert

Hallo Sabine,

der Test läuft meiner Meinung nach korrekt, da ein MD_LegalConstraints-Element vorhanden ist, aber kein MD_LegalConstraints/useConstraints/MD_RestrictionCode-Element.

Gruß
Sven

#7 Person Von Sabine Schütze vor etwa 3 Jahren aktualisiert

Hallo Sven,
ich gebe Dir Recht. Der Test läuft korrekt. Demnach ist der 1. Prüfschritt des Tests zu verbessern. Ich habe dazu ein Ticket im redmine des AK MD angelegt, siehe https://redmine.gdi-de.org/issues/905.

#8 Von Anonym vor fast 3 Jahren aktualisiert

  • Status wurde von Rückfrage zu Erledigt geändert

#9 Person Von Gerd Weber vor 4 Tagen aktualisiert

  • Zielversion GDI-DE Testsuite Release 2.1.31 wurde gelöscht
  • Kategorie GDI-DE Metadaten v1.1 wurde gelöscht
  • Projekt wurde von GDI-DE Testsuite zu Testsuite 2.1.30 Dokumentation geändert

Auch abrufbar als: Atom PDF