Projekt

Allgemein

Profil

Support #848

Person Avatar?id=734&size=22x22

Meldungen „SSL peer shut down incorrectly“ nicht erklärbar

Von Ticketmelder GDI-DE vor mehr als 2 Jahren hinzugefügt. Vor mehr als 1 Jahr aktualisiert.

Status:
Neu
Priorität:
Mittel
Zugewiesen an:
Gregor Scharf
Kategorie:
INSPIRE View Service - WMS 1.3

Beschreibung

Beim Testen von INSPIRE-WMS machen uns die Meldungen „SSL peer shut down incorrectly“ das Leben schwer!
Bisher glaubten wir, dass es etwas mit den zahlreichen GetMap-Requests in allen Kombinationen aus Layern und Bezugssystemen zu tun hat. Die Anzahl der Meldungen schwankt jedoch bei Wiederholungen des Tests. Nun haben wir auch einmal die Standard-WMS-Tests mitlaufen lassen und bekommen auch dort diese (uns bisher nicht erklärbare) Meldung in anderem Zusammenhang.
Was verbirgt sich dahinter? Wo liegt das Problem?
Aktuell habe ich es mit dem Dienst unter https://www.wms.nrw.de/geobasis/wms_nw_inspire-verwaltungseinheiten_atkis-basis-dlm_test? probiert.

tls_noe.png (160 KB) tls_noe.png Gregor Scharf, 12.06.2017 10:59
weiterhin_SSL-Fehler.png (35,1 KB) weiterhin_SSL-Fehler.png Peter Kochmann, 12.06.2017 16:04
pdfReport_WMS_20170811-08.pdf (697 KB) pdfReport_WMS_20170811-08.pdf Lauf von ca. 8 Uhr Peter Kochmann, 11.08.2017 12:07
pdfReport_WMS_20170811-10.pdf (697 KB) pdfReport_WMS_20170811-10.pdf Lauf von ca. 10 Uhr Peter Kochmann, 11.08.2017 12:07

Historie

#1 Von Anonym vor mehr als 2 Jahren aktualisiert

  • Kategorie wurde auf INSPIRE View Service - WMS 1.3 gesetzt
  • Zugewiesen an wurde auf Gregor Scharf gesetzt
  • Zielversion wurde auf GDI-DE Testsuite Release 2.1.30 gesetzt
  • Privat wurde von Ja zu Nein geändert

#2 Von Anonym vor mehr als 2 Jahren aktualisiert

  • Zielversion wurde von GDI-DE Testsuite Release 2.1.30 zu GDI-DE Testsuite Release 2.1.31 geändert

#3 Avatar?id=734&size=24x24 Von Gregor Scharf vor mehr als 2 Jahren aktualisiert

  • Status wurde von Neu zu Abnahmephase geändert
  • Zugewiesen an wurde von Gregor Scharf zu Anonym geändert

Nach Aenderung in der setenv.sh von

JAVA_OPTS="$JAVA_OPTS -Dhttps.protocols=TLSv1.2"

auf

JAVA_OPTS="$JAVA_OPTS -Dhttps.protocols=TLSv1.2,TLSv1.1,TLSv1"

kommen keine SSL-Fehler mehr.

#4 Person Von Peter Kochmann vor mehr als 2 Jahren aktualisiert

Ich laufe weiterhin auf den genannten Fehler, u.a. mit dem WMS https://www.wms.nrw.de/geobasis/wms_nw_inspire-verwaltungseinheiten_alkis?
Die URL aus der obigen Beschreibung ist nicht mehr relevant!

#5 Von Anonym vor mehr als 2 Jahren aktualisiert

  • Status wurde von Abnahmephase zu Neu geändert
  • Zugewiesen an wurde von Anonym zu Gregor Scharf geändert

#6 Avatar?id=734&size=24x24 Von Gregor Scharf vor mehr als 2 Jahren aktualisiert

Peter Kochmann schrieb:

Ich laufe weiterhin auf den genannten Fehler, u.a. mit dem WMS https://www.wms.nrw.de/geobasis/wms_nw_inspire-verwaltungseinheiten_alkis?

Es dauert zwar laenger als einen Tag, den WMS zu testen, aber ich bekomme keinen SSL-Fehler, siehe Anhang.

#7 Person Von Peter Kochmann vor mehr als 2 Jahren aktualisiert

Kann ich leider nicht bestätigen: Ich bekomme immer noch denselben Fehler (s. Anhang)!

#8 Avatar?id=734&size=24x24 Von Gregor Scharf vor mehr als 2 Jahren aktualisiert

Hm, vllt. liegt es am QOS bzw. an der automatischen Ausfuehrung, weil dort habe ich noch nichts geaendert.

#9 Avatar?id=734&size=24x24 Von Gregor Scharf vor mehr als 2 Jahren aktualisiert

  • Status wurde von Abnahmebereit zu In Bearbeitung geändert

Ich kann den Fehler jetzt nachvollziehen (bei der automatischen Ausfuehrung).

Obwohl ich heute

-Dhttps.protocols=TLSv1.2,TLSv1.1,TLSv1
-Djdk.tls.client.protocols=TLSv1.2,TLSv1.1,TLSv1

in die QOS-Konfiguration eingebaut habe, tritt der Fehler immer noch auf. Mal sehen was Wireshark sagt.

#10 Person Von Peter Kochmann vor mehr als 2 Jahren aktualisiert

Gibt es hierzu inzwischen Neuigkeiten? Wir stranden weiterhin mit diesem Fehler!
Nach Beheben anderer Defizite geht es aktuell um https://www.wms.nrw.de/geobasis/wms_nw_inspire-verwaltungseinheiten_alkis_test?
Oder auch https://www.wms.nrw.de/geobasis/wms_nw_inspire-verwaltungseinheiten_atkis-basis-dlm?

#11 Person Von Peter Kochmann vor mehr als 2 Jahren aktualisiert

Die Fragezeichen in allen OnlineRessource-Einträgen in den Capabilities waren leider nicht die Lösung.
Wir stellen fest, dass es auch nicht immer dieselben GetMap-Requests sind, die derart enden. Ein grundsätzliches, funktionales Problem schließen wir daher aus.
Wir wundern uns aber auch ein wenig über die Reihenfolge der Testschritte, die von Lauf zu Lauf offensichtlich unterschiedlich sein kann, und außerdem, dass einzelne GetMap-Requests sogar wiederholt protokolliert werden.

#12 Person Von Anja Litka vor etwa 2 Jahren aktualisiert

Testergebnisse zum Dienst: https://www.wms.nrw.de/geobasis/wms_nw_inspire-verwaltungseinheiten_alkis_test?request=GetCapabilities&version=1.3.0&service=WMS
Zeitraum: 1 Woche (jeweils zu unterschiedlichen Zeiten)
Einstellungen: Testklasse: Kartendienste | Map Services: INSPIRE View Service based on WMS 1.3.0, Konformitätsklassen: WMS 1.3.0: INSPIRE Requirements Interoperability - WMS 1.3.0: INSPIRE Requirements Network Services - WMS 1.3.0: ISO Requirements)

Art des Testverfahrens: manueller (händischer) Start:
1 - 301 - 0 (Fehlermeldung: SSL peer shut down incorrectly)
1 - 304 - 0 (Fehlermeldung: SSL peer shut down incorrectly)
1 - 184 - 0 (Fehlermeldung: SSL peer shut down incorrectly)
1 - 210 - 0 (Fehlermeldung: SSL peer shut down incorrectly)
38 - 0 - 0 (Fehlermeldung: line:-1, column: -1; Premature end of file.)
39 - 0 - 0 (Fehlermeldung: line:-1, column: -1; Premature end of file.)
1 - 148 - 0 (Fehlermeldung: SSL peer shut down incorrectly)
1 - 143 - 0 (Fehlermeldung: SSL peer shut down incorrectly)
38 - 1 - 0 (Fehlermeldung: line:-1, column: -1; Premature end of file.)
38 - 0 - 0 (Fehlermeldung: line:-1, column: -1; Premature end of file.)

Art des Testverfahrens: automatischer Start (Ausführungswiederholung alle 4h):
1 - 215 - 1 (Fehlermeldung: SSL peer shut down incorrectly)
1 - 297 - 1 (Fehlermeldung: SSL peer shut down incorrectly)
1 - 295 - 0 (Fehlermeldung: SSL peer shut down incorrectly)
1 - 291 - 1 (Fehlermeldung: SSL peer shut down incorrectly)
41 - 4 - 1 (Fehlermeldung: line:-1, column: -1; Premature end of file.)
1 - 230 - 1 (Fehlermeldung: SSL peer shut down incorrectly)
1 - 157 - 0 (Fehlermeldung: SSL peer shut down incorrectly)
42 - 112 - 0 (Fehlermeldung: line:-1, column: -1; Premature end of file.)
38 - 0 - 0 (Fehlermeldung: SSL peer shut down incorrectly)
1 - 99 - 9 (Fehlermeldung: SSL peer shut down incorrectly)

#13 Person Von Peter Kochmann vor etwa 2 Jahren aktualisiert

Wir haben einzelne Dienste trotz dieses ungelösten Fehlers inzwischen in Produktion überführt.
Auch der hier dokumentierte https://www.wms.nrw.de/geobasis/wms_nw_inspire-verwaltungseinheiten_alkis_test? gehört dazu. Neue URL ist jetzt https://www.wms.nrw.de/geobasis/wms_nw_inspire-verwaltungseinheiten_alkis?request=GetCapabilities&version=1.3.0&service=WMS

#14 Avatar?id=734&size=24x24 Von Gregor Scharf vor fast 2 Jahren aktualisiert

  • Status wurde von In Bearbeitung zu Rückfrage geändert

#15 Avatar?id=734&size=24x24 Von Gregor Scharf vor fast 2 Jahren aktualisiert

  • Status wurde von Rückfrage zu Abnahmebereit geändert
  • Zugewiesen an wurde von Gregor Scharf zu Anja Litka geändert

Ich habe die Anzahl maximal oeffnenbarer Dateien und Sockets erhoeht auf dem Testsuite-Server und auf dem Datenbank-Server. Kannst Du mal testen, ob das was gebracht hat? Fuer mich sieht es so aus! :)

$ ulimit -n
1024

hochgesetzt auf

$ ulimit -n
65536

via

/etc/security/limits.conf
---
*       soft    nofile  65536
*       hard    nofile  65536
root    soft    nofile  65536
root    hard    nofile  65536

und via

/etc/pam.d/common-session
---
session required pam_limits.so

Geoeffnete Dateien und Sockets auf der Live-Testsuite:

$ lsof | wc -l
63110

Analog auf dem Datenbank-Server:

$ lsof | wc -l
9169

#16 Avatar?id=734&size=24x24 Von Gregor Scharf vor fast 2 Jahren aktualisiert

  • Status wurde von Abnahmebereit zu Rückfrage geändert
  • Zugewiesen an wurde von Anja Litka zu Gregor Scharf geändert

Hmpf, mit der automatischen Ausfuehrung bekomme ich immer noch viele "SSL peer shut down incorrectly"-Fehler. :(

#17 Von Anonym vor fast 2 Jahren aktualisiert

Da schließe ich mich an! Fehlermeldung und ungefähre Fallzahlen bleiben gleich, aber das Ganze läuft jetzt schneller!

#18 Person Von Peter Kochmann vor fast 2 Jahren aktualisiert

Ich hätte mich ja vorher auch mal anmelden können. #17 ist von mir...

#19 Avatar?id=734&size=24x24 Von Gregor Scharf vor mehr als 1 Jahr aktualisiert

  • Status wurde von Rückfrage zu Neu geändert

Ich hab noch keine Idee.

#20 Person Von Anja Litka vor mehr als 1 Jahr aktualisiert

Nach einem Test mit dem niederländischen Validator, habe ich folgende Fehler (fehlende Einträge) ermitteln können:

TG Requirement 37, 38: INSPIRE Resource Identifier: all Layers with a Name have an Identifier and a declared Authority for that Identifier = Layer: INSPIRE Administrative Units has no MetadataURL.

Reference TG Requirement 46: All Layers with a Name have a Style (For layer: INSPIRE Administrative Units the Identifier, the Identifier authority attribute and/or AuthorityURL are missing. All have to be present.= = Layer: INSPIRE Administrative Units has no Style.

G Requirement 8, 9: Capabilities implement the extended metadata. Validate to declared XML Schema (xsi:schemaLocation) = org.xml.sax.SAXException: Fatal error: org.xml.sax.SAXParseException; lineNumber: 1; columnNumber: 505; cvc-elt.1: Cannot find the declaration of element 'WMS_Capabilities'. Response did not meet schema 'http://inspire.ec.europa.eu/schemas/inspire_vs/1.0 https://www.gis.nrw.de/arcgis/rest/directories/arcgisforinspire/schema/networkservices/inspire_vs/1.0/inspire-wms-extension.xsd'.

#21 Person Von Peter Kochmann vor mehr als 1 Jahr aktualisiert

M.W. ist es o.k., dass der oberste Layer (der eigentlich nur ein Gruppen-Layer ist und selbst gar keine Daten zeigt) keine Daten-Dienste-Kopplung hat. Wohin sollte die auch zeigen, wenn darunter Layer mit Daten aus verschiedenen Quellen (mit jeweils eigenen Metadaten) kommen? Wir haben auch mehrere Beispiele, dass die Testsuite sich daran nicht stößt und es auch nichts mit dem angeblichen "SSL-shutdown" zu tun hat.
Der letzte Eintrag scheint interessanter, weil er auf ArcGIS-interne Dinge zeigt. Die Extended Capabilities sind nämlich definitiv drin!

Auch abrufbar als: Atom PDF